16 Nisan 2024 01:39

Anasayfa

undefined...

Debian/Ubuntu tabanlı işletim sistemi kullanırken paket güncelleme sırasında aşağıdaki hatayı/uyarıyı alıyorsanız sebebi sorun yaratan paket-ler-in hold (tutma gibi) olarak işaretlenmiş olması.

 

Örnek:

apt-get -y install libidn2-0 libidn2-dev ..
Reading package lists...
Building dependency tree...
Reading state information...
The following held packages will be changed:
libidn2-0
The following packages will be upgraded:
libidn2-0 libidn2-dev
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
E: Held packages were changed and -y was used without --allow-change-held-packages.
 

Çözüm

Listeyi gör

apt-mark showhold 

apt-mark unhold libidn2-0

apt update && apt upgrade -y

Ubuntu

hakkında diğer konular

Makdos Bilişim Teknolojileri 2015 - 2022